• Announcements

    • IMPORTANT - REACH US IN THE NEW FORUM   05/04/2017

      Ladies and gentlemen ATTENTION please:
      It's time to move into a new house!
        As previously announced, from now on IT WON'T BE POSSIBLE TO CREATE THREADS OR REPLY in the old forums. From now on the old forums will be readable only. If you need to move/copy/migrate any post/material from here, feel free to contact the staff in the new home. We’ll be waiting for you in the NEW Forums!

      https://community.blackdesertonline.com/index.php

      *New features and amazing tools are waiting for you, even more is yet to come in the future.. just like world exploration in BDO leads to new possibilities.
      So don't be afraid about changes, click the link above and follow us!
      Enjoy and see you on the other side!  
    • WICHTIG: Das Forum ist umgezogen!   05/04/2017

      Damen und Herren, wir bitten um Eure Aufmerksamkeit, es ist an der Zeit umzuziehen!
        Wie wir bereits angekündigt hatten, ist es ab sofort nicht mehr möglich, neue Diskussionen in diesem Forum zu starten. Um Euch Zeit zu geben, laufende Diskussionen abzuschließen, könnt Ihr noch für zwei Wochen in offenen Diskussionen antworten. Danach geht dieses Forum hier in den Ruhestand und das NEUE FORUM übernimmt vollständig.
      Das Forum hier bleibt allerdings erhalten und lesbar.   Neue und verbesserte Funktionen warten auf Euch im neuen Forum und wir arbeiten bereits an weiteren Erweiterungen.
      Wir sehen uns auf der anderen Seite!

      https://community.blackdesertonline.com/index.php Update:
      Wie angekündigt könen ab sofort in diesem Forum auch keine neuen Beiträge mehr veröffentlicht werden.
    • IMPORTANT: Le nouveau forum   05/04/2017

      Aventurières, aventuriers, votre attention s'il vous plaît, il est grand temps de déménager!
      Comme nous vous l'avons déjà annoncé précédemment, il n'est désormais plus possible de créer de nouveau sujet ni de répondre aux anciens sur ce bon vieux forum.
      Venez visiter le nouveau forum!
      https://community.blackdesertonline.com
      De nouvelles fonctionnalités ainsi que de nouveaux outils vous attendent dès à présent et d'autres arriveront prochainement! N'ayez pas peur du changement et rejoignez-nous! Amusez-vous bien et a bientôt dans notre nouveau chez nous

FPS drops in combat


11 posts in this topic

Posted (edited)

Hi i recently started playing BDO and first thing i noticed was a fps drops in combat. Framerate is stable most of the time im getting 55~60 fps at highest settings(with the exception of extended LOD and high end mode)  but as soon as i start fight ohh boy framerate spikes down to something around 33~40 its most noticable when im doing combos. First thing i done was lowering the graphic and it resulted in the same situation good framerate outside the fight but drops in combat ( i wasnt going under slighty high graphic and medium textures i have 970 after all ;) ). Then i reduced my res from 2560x1080 to 1920x800 same thing but frame rate in combat jump up to 36-48 fps. After my "sucesfull" attemp to make game more playeble i decided to change settings in Nvidia control panel. I turned off vsync and set texture filtering to performance and gues what no effect at all... Did some of you get the same issues ? and how can i fix them ? 

One more thing sorry if i misspelled something, English isn't my native language after all :)

My rig: 

Graphic card: palit gtx 970 jet stream overclocked Driver(378.92)

Processor: Intel i5 6600k overclocked to 4.3 ghz 

RAM: 16GB DDR4

PSU: 700w ( i know an overkill ;))

MBO: ASrock z170 pro 4s

 

Edited by K4K4O

Share this post


Link to post
Share on other sites

Posted

I had the same issues with this build:

  • GTX 1060
  • i5 6600k overclocked 4.4Ghz
  • 16GB RAM DDR4
  • PSU 650w
  • ASrock z170 Pro4s

I recently upgraded to the i7 7700k (overclocked to 4.7Ghz). I got FPS improvements that were enough to make a difference during battle, but it's still no where near perfect. I would suggest upgrading to the i7 6700k, but you should not expect this to completely solve your FPS issues during battle.

I also play with the Nvidia settings, maybe once a week, but it doesnt seem to do much.

Share this post


Link to post
Share on other sites

Posted (edited)

i did some testing and here's the results

the game has no fps issues! the problem is the netcode that masks lag by frame skipping instead of predictive sync. let me explain...

lets say you get 60fps, so you are being shown 1 frame every 16ms. if you get a bit of lag that makes your connection lose 16ms or more, the game instead of making you go 16ms back or keep things fluid by calculating the lost frame based on your current action, it will skip the frame entirely dropping the fps counter to 59. have this happen several times in 1 second and the fps drops ever lower.

Edited by Teknoman2

Share this post


Link to post
Share on other sites

Posted (edited)

i did some testing and here's the results

the game has no fps issues! the problem is the netcode that masks lag by frame skipping instead of predictive sync. let me explain...

lets say you get 60fps, so you are being shown 1 frame every 16ms. if you get a bit of lag that makes your connection lose 16ms or more, the game instead of making you go 16ms back or keep things fluid by calculating the lost frame based on your current action, it will skip the frame entirely dropping the fps counter to 59. have this happen several times in 1 second and the fps drops ever lower..

Disclaimer

"I try to verify your teory by testing it by my self. So  i fired up torrent download to stress my network conection but regadles of ordinary internet lags it wasn't affecting frame rate at all. "

So i fixed it kinda.... 

I messed up with settings again and i fund out one thing i have fps drops only in my native res 2560x1080 the 1920x1080 was working fine with drops only to 50fps. I was pleasantly supprised when i noticed that upscaling setting is also fixing the isuue when im in 21:9 screan ratio but the game looks ugly in that low res. So to fix that i opened nvidia setiings and set up DSR(Dynamic Super Resolution) to 1.25x native resolution then i set in game resolution to that value and turn on upscale and thats it no fps issues 

In conclusion i think its a problem with particles or ressolution issues and i hope it will be soon fixed by devs , after my tweaks game isnt that appeling to the eye but is more playable at least.. and it runs in 21:9 xD 

I end up with those settings 

Resolution 2804 x 1183

Texture high 

Graphic very high with improve distance and high end mode turrned off 

Optymiztion: upscale turned on

 

Edited by K4K4O

Share this post


Link to post
Share on other sites

Posted

So to fix that i opened nvidia setiings and set up DSR(

Dynamic Super Resolution) to 1.25x native resolution then i set in game resolution to that value and turn on upscale and thats it no fps issues 

In conclusion i think its a problem with particles or ressolution issues and i hope it will be soon fixed by devs , after my tweaks game isnt that appeling to the eye but is more playable at least.. and it runs in 21:9 xD 

I end up with those settings

haha what a hassle, but nice work trying stuff out :D

I can relate to how you think its a resolution issue,because often when playing around with settings alot of things seems to get rendered a different resolution.

Some settings make the game look skewed and unnatural, even though i am only trying to make it run better xD

Share this post


Link to post
Share on other sites

Posted

Check the power management settings in your BIOS. They can throttle your CPU and cause framerate issues

Share this post


Link to post
Share on other sites

Posted

Check the power management settings in your BIOS. They can throttle your CPU and cause framerate issues

My cpu isn't throtteling at all i run cuple of stress tests to ensure that. Anyway i find the way to fix my issues for now and since is probably a problem with a game and not my setup i don't see a point to continue this thread ,regardless though thanks for help guys :) 

Share this post


Link to post
Share on other sites

Posted

I was running stress tests as well, and it wasn't finding the throttle. Check to see how close to maximum frequency your CPU is running at. Mine was throttling to 1400 MHz, when it has a max of 4.2 GHz. It was still passing stress tests though.

Share this post


Link to post
Share on other sites

Posted

I have the same problem since 1.5 week, it really is unplayable for me. Normally i have 60 fps but as soon as i engage in combat it goes down to 40->30->20 and sits there until i go out of combat. I've tried several things so far:

  1. Fresh Windows 10 64bit install 
  2. Different AMD GPU drivers
  3. Installation on 2 different SSD's
  4. Defrag of the SSD's
  5. Multiple settings in both AMD software + ingame settings. 
  6. Network tests like stated above this post (to see if it was ping related)
  7. Different chars on different channels
  8. Closing COherent UI 
  9. Marketplace my listings UI trick
  10. Prioritizing the BDO processes
  11. BIOS upgrade. 
  12. Adjusted overclock settings.

Yes.. i tried alot because it's unplayable for me now. The problem started all of a sudden. I did not made any changes to my system soft or hardware related matters prior to this issue.

I run a i2500k OC'd @ 4.6ghz + R9 390x and 8 gb ddr3 and did not have any problems before. (asside from the usual fps drops).

A fix would be nice...

 

Share this post


Link to post
Share on other sites

Posted

I have the same problem since 1.5 week, it really is unplayable for me. Normally i have 60 fps but as soon as i engage in combat it goes down to 40->30->20 and sits there until i go out of combat. I've tried several things so far:

  1. Fresh Windows 10 64bit install 
  2. Different AMD GPU drivers
  3. Installation on 2 different SSD's
  4. Defrag of the SSD's
  5. Multiple settings in both AMD software + ingame settings. 
  6. Network tests like stated above this post (to see if it was ping related)
  7. Different chars on different channels
  8. Closing COherent UI 
  9. Marketplace my listings UI trick
  10. Prioritizing the BDO processes
  11. BIOS upgrade. 
  12. Adjusted overclock settings.

Yes.. i tried alot because it's unplayable for me now. The problem started all of a sudden. I did not made any changes to my system soft or hardware related matters prior to this issue.

I run a i2500k OC'd @ 4.6ghz + R9 390x and 8 gb ddr3 and did not have any problems before. (asside from the usual fps drops).

A fix would be nice...

 

 

I have sent in two tickets regarding this, and gm said that this will be fixed some time in april, got the same issue myself just suddenly started 2ish weeks ago.

Share this post


Link to post
Share on other sites

Posted

 

I have sent in two tickets regarding this, and gm said that this will be fixed some time in april, got the same issue myself just suddenly started 2ish weeks ago.

That's good news. I already felt it was some ingame bug causing the issue. Even more when i ruled out most of the other issues that could be causing it. Now let's hope it will be truly fixed sometime soon.

Share this post


Link to post
Share on other sites