• Announcements

    • IMPORTANT - REACH US IN THE NEW FORUM   05/04/2017

      Ladies and gentlemen ATTENTION please:
      It's time to move into a new house!
        As previously announced, from now on IT WON'T BE POSSIBLE TO CREATE THREADS OR REPLY in the old forums. From now on the old forums will be readable only. If you need to move/copy/migrate any post/material from here, feel free to contact the staff in the new home. We’ll be waiting for you in the NEW Forums!

      https://community.blackdesertonline.com/index.php

      *New features and amazing tools are waiting for you, even more is yet to come in the future.. just like world exploration in BDO leads to new possibilities.
      So don't be afraid about changes, click the link above and follow us!
      Enjoy and see you on the other side!  
    • WICHTIG: Das Forum ist umgezogen!   05/04/2017

      Damen und Herren, wir bitten um Eure Aufmerksamkeit, es ist an der Zeit umzuziehen!
        Wie wir bereits angekündigt hatten, ist es ab sofort nicht mehr möglich, neue Diskussionen in diesem Forum zu starten. Um Euch Zeit zu geben, laufende Diskussionen abzuschließen, könnt Ihr noch für zwei Wochen in offenen Diskussionen antworten. Danach geht dieses Forum hier in den Ruhestand und das NEUE FORUM übernimmt vollständig.
      Das Forum hier bleibt allerdings erhalten und lesbar.   Neue und verbesserte Funktionen warten auf Euch im neuen Forum und wir arbeiten bereits an weiteren Erweiterungen.
      Wir sehen uns auf der anderen Seite!

      https://community.blackdesertonline.com/index.php Update:
      Wie angekündigt könen ab sofort in diesem Forum auch keine neuen Beiträge mehr veröffentlicht werden.
    • IMPORTANT: Le nouveau forum   05/04/2017

      Aventurières, aventuriers, votre attention s'il vous plaît, il est grand temps de déménager!
      Comme nous vous l'avons déjà annoncé précédemment, il n'est désormais plus possible de créer de nouveau sujet ni de répondre aux anciens sur ce bon vieux forum.
      Venez visiter le nouveau forum!
      https://community.blackdesertonline.com
      De nouvelles fonctionnalités ainsi que de nouveaux outils vous attendent dès à présent et d'autres arriveront prochainement! N'ayez pas peur du changement et rejoignez-nous! Amusez-vous bien et a bientôt dans notre nouveau chez nous
Sign in to follow this  
Followers 0

Unable to select my best graphics card


24 posts in this topic

Posted

Hello everyone!

I started downloading the game and checked out the settings. I'm starting to panic a little bit because the launcher only seems to see my crappy Intel graphics card and not my good NVIDIA one. I went into the NVIDIA control panel and put the global settings to "High-performance NVIDIA processor" but the launcher still can't see it after a restart. I have a similar problem with another game (though that one is a few years old). The game refuses to use my NVIDIA card so I'm forced to run it on minimum graphics... I don't think that Intel card is able to run BDO even on minimum graphics if it has problems running the other old game. Please tell me there's a fix for this, I don't want to miss out on BDO because my computer's stupid. Q_Q

Somebody please save me! D:

BD graphics card selection.jpg

Share this post


Link to post
Share on other sites

Posted

And your monitor is actually set to use the Nvidia right now?

I have an HD4600 too but don't have this problem with the RU/JP game. I haven't tried the launcher for EU/NA yet though.

Share this post


Link to post
Share on other sites

Posted (edited)

Make sure your default monitor configuration is running through your discrete gpu as opposed to the Intel integrated one. This is assuming you're running a multi-monitor setup with one of your monitors jacked into your mobo ;P
though it could effect you if you're still jacked into your mobo with a single monitor as opposed to your gpu.

Tbh, you've only mentioned two occurrences but I'm going to assume that you've got your monitor plugged into your motherboard as opposed to plugged into your graphics card. If this is the case, then the only graphics option your computer will have is the intel one. Your computer will still acknowledge the graphics cards existence, because it's there, in the motherboard. But you have no displays hooked into it, so therefore no display can use it(unless you've got some type of psychotic software that does crazy virtualblahfuoadfhjd) anywho. Make sure that your monitor is not plugged into a DVI/VGA/HDMI/Etc. port on the motherboard, but is plugged into one of the ports on the graphics card. 

 

LAYER ONE OSI BABY MMMM. GOTTA LOVE THAT STUFF AM I RIGHT...?

Edited by War

Share this post


Link to post
Share on other sites

Posted

If you didn't do this, go to "config surround, physX", and change your processor to Nvidia's.  I would also add BDO to the program settings instead of global.

Share this post


Link to post
Share on other sites

Posted

Ok so I have a dragon gaming laptop and the graphics card is a GeForce GTX 970M. War I'm not sure what you mean by that. D: How do I get to the default monitor configurations?

My NVIDIA control panel settings:

Adjust image settings with preview (3D settings) = Use advanced 3D image settings (highest quality)

Manage 3D settings: This damn thing keeps resetting to Intel no matter how many times I set and apply the global settings to always use NVIDIA and also set each individual game/program to use NVIDIA in the program settings tab. Does anyone know how to fix that?

Set PhysX configuration: GeForce GTX 970M (that one doesn't seem to reset all the time like the Manage 3D settings tab)

Share this post


Link to post
Share on other sites

Posted

Ok so I have a dragon gaming laptop and the graphics card is a GeForce GTX 970M. War I'm not sure what you mean by that. D: How do I get to the default monitor configurations?

My NVIDIA control panel settings:

Adjust image settings with preview (3D settings) = Use advanced 3D image settings (highest quality)

Manage 3D settings: This damn thing keeps resetting to Intel no matter how many times I set and apply the global settings to always use NVIDIA and also set each individual game/program to use NVIDIA in the program settings tab. Does anyone know how to fix that?

Set PhysX configuration: GeForce GTX 970M (that one doesn't seem to reset all the time like the Manage 3D settings tab)

wars advice was if you had a computer with monitors not a laptop.

try this (just a quick google search so not sure how helpfull)

https://support.lenovo.com/nl/nl/documents/ht078706

Share this post


Link to post
Share on other sites

Posted

What's your power management mode?  Choose max performance, non of that adaptive/power saver crap if you are gaming.  Same goes for your laptop's power management.

Share this post


Link to post
Share on other sites

Posted

Ok so I have a dragon gaming laptop and the graphics card is a GeForce GTX 970M. War I'm not sure what you mean by that. D: How do I get to the default monitor configurations?

My NVIDIA control panel settings:

Adjust image settings with preview (3D settings) = Use advanced 3D image settings (highest quality)

Manage 3D settings: This damn thing keeps resetting to Intel no matter how many times I set and apply the global settings to always use NVIDIA and also set each individual game/program to use NVIDIA in the program settings tab. Does anyone know how to fix that?

Set PhysX configuration: GeForce GTX 970M (that one doesn't seem to reset all the time like the Manage 3D settings tab)

Oh a laptop, my bad. Disregard everything I said! Heh..hehehheh..

Share this post


Link to post
Share on other sites

Posted (edited)

What's your power management mode?  Choose max performance, non of that adaptive/power saver crap if you are gaming.  Same goes for your laptop's power management.

Yep both of these are always set to max performance.

Oh a laptop, my bad. Disregard everything I said! Heh..hehehheh..

Oh ok!

I found this [see screen shot] but I'm not sure if it has any influence. There doesn't seem to be an option to change it to NVIDIA.

wars advice was if you had a computer with monitors not a laptop.

try this (just a quick google search so not sure how helpfull)

https://support.lenovo.com/nl/nl/documents/ht078706

I'll try what it says in the link. Maybe setting it through computer management will stop it from resetting all the time. >.< EDIT: It doesn't. ._.

Monitor GC.jpg

Edited by Kinna
Update on a statement.

Share this post


Link to post
Share on other sites

Posted

tell us how it worked out :P

Share this post


Link to post
Share on other sites

Posted

tell us how it worked out :P

See edit; it didn't work. >.<

I think the main problem is that the NVIDIA control panel doesn't seem to be able to actually save the settings where I tell it to use the NVIDIA card in global settings and program settings. Every time I open the NVIDIA control panel, it's suddenly back to Intel. Q_Q

Btw, thanks for trying to help me everyone!

Share this post


Link to post
Share on other sites

Posted

MAYBE this. it's a bit similar to the previous fix but who knows :P  also you'd have to restart the launcher for it to have a result

Share this post


Link to post
Share on other sites

Posted

Yep, that's what I keep doing MrGrim. I apply the NVIDIA processor to both the Global Settings and Program Settings. Every time I open up the control panel again, it has reset to Intel.

Share this post


Link to post
Share on other sites

Posted

Yep, that's what I keep doing MrGrim. I apply the NVIDIA processor to both the Global Settings and Program Settings. Every time I open up the control panel again, it has reset to Intel.

For program settings, you selected BDO as the application?

Share this post


Link to post
Share on other sites

Posted

You might need to go into the Bios and disable Optimus. Use the discrete GPU only (Your 970M.)

Share this post


Link to post
Share on other sites

Posted

Ok i got this

http://www.tomshardware.co.uk/answers/id-2051434/nvidia-control-panel-saving-settings.html

and this

https://forums.geforce.com/default/topic/525191/geforce-experience/nvidia-installer-failed/post/4244579/#4244579

It's to attempt to fix your nvidia control panel not saving it's settings

I suggest starting with going to the nvidia website to download the latest drivers.
then go to control panel > uninstall a program
then uninstall all your current nvidia drivers completely check your folders at C:\Program Files\NVIDIA Corporation to see if it's all gone
Reboot
install the drivers you just downloaded. you don't need everything mainly just the audio, video, physics drivers and if you like it the geforce experience.
and then reboot again
check if it works then :)  if not. then maybe those links who are quite a lot more thorough in deleting the drivers may work. but no guarantees

No clue what smexy recommended but that might work too :)

Share this post


Link to post
Share on other sites

Posted

copy paste from reddit: This might actually work far better. should've thought of this first.

 

Yeah i know i'am kinda late.... but i had same problem here's the fix:

windows 8.1 x64 btw

C:\Program Files\NVIDIA Corporation\Control Panel Client

nvcplui

right click/compatibility/check run this program as administrator BOOM!

Share this post


Link to post
Share on other sites

Posted

For program settings, you selected BDO as the application?

Yes.

You might need to go into the Bios and disable Optimus. Use the discrete GPU only (Your 970M.)

I will look into that! I did try disabling the Intel graphics card to force the laptop to use the NVIDIA but it broke stuff (ie: couldn't adjust the brightness of my screen anymore).

-----------------------------------------

MrGrim:

I'm currently downloading the latest driver that was released in december, tho my version is from november and I've had this problem for a year, so I'd be surprised if it suddenly got fixed with this. Also, I tried running the control panel as admin but it doesn't work either. =/

Share this post


Link to post
Share on other sites

Posted

Go to Nvidia Control Panel - Manage 3d Settings:

Switch Preferred Graphics Processor: to High Performance Nvidia Processor.

Click Apply.

This will show only your GTX970M card in the option menu of Game launcher.

 

That's how it works for my Laptop.

That's how it works on my laptop too; except that the settings are not being saved (yes I click apply and wait till it's "saved"). Many have already suggested this and I'm getting a little tired of repeating myself. :S

Share this post


Link to post
Share on other sites

Posted

Go to Nvidia Control Panel - Manage 3d Settings:

Switch Preferred Graphics Processor: to High Performance Nvidia Processor.

Click Apply.

This will show only your GTX970M card in the option menu of Game launcher.

 

That's how it works for my Laptop.

His problem is that the control panel wont save that. which is a bug in the control panel and a lot of people have issues with it really.

Share this post


Link to post
Share on other sites

Posted

Wow okay. So I downloaded the new version of the driver for my graphics card (which was only one month apart from the version I had) and it suddenly decided to allow me to save my settings. I wonder why it took over a year for this to fix itself lol. I think it had to do with the fact that I told it to completely wipe all settings. Sadly it still doesn't work for my old game but at least it does for BDO! :D

Share this post


Link to post
Share on other sites

Posted

Great to hear!

i feel this is appropriate

111.thumb.jpg.9f309717376d8bb07f48d4ad0e

Share this post


Link to post
Share on other sites

Posted

Dude got to device manager and disable that Intel crap (if you can) lol

Share this post


Link to post
Share on other sites

Posted

Just right click the game and run it with the nvidia gpu selected

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0